Aiutate a far includere OpenShot in Ubuntu

Mi voglio rivolgere a tutti coloro che hanno un account su Launchpad, e a tutti quelli che hanno sempre detto “non abbiamo un buon editor video per Linux”. Come vi ho già detto qualche tempo fa, noi abbiamo il nostro editor davvero interessante, ed evolve ogni giorno!🙂

Ora avete la possibilità di aiutare a far includere OpenShot nei repository di Ubuntu dalla versione 10.04 in poi. A questo indirizzo sono riportate tutte le istruzioni. Si tratta in sostanza di visitare questa segnalazione di bug, fare il login e cliccare sulla dicitura “This bug affects X people. Does this bug affect you?” e selezionare la voce “Yes, it affects me“. Di fatto questo comporta un vostro voto a favore dell’inclusione.😉

Già che ci sono, vi segnalo che è uscito il manuale utente di OpenShot, leggetelo!

Aggiornamento 09/01/2010: mi è giunta la notizia che è finalmente uscita la versione 1.0 di OpenShot! Muflone l’ha subito segnalato e mi fa piacere che mi abbia anche menzionato. A proposito, provate il tema Tango incluso in OpenShot, è spettacolare.

Aggiornamento 17/02/2010: finalmente OpenShot è stato incluso!

44 pensieri su “Aiutate a far includere OpenShot in Ubuntu

  1. Stai parlando della possibilità di averlo nei repo o di integrarlo nelle installazioni predefinite? Se l’ipotesi è la seconda Openshot è un’ottimo progetto ma su ubuntu l’unica scelta sensata IMHO è pitivi, questo per vari motivi:

    – chi sviluppa pitivi è un’importante azienda nel mondo dell’opensource
    – lo sviluppo di pitivi sta portando ottime novità in gstreamer
    – Openshot è tutt’altro che integrato nel DE

    Le mancanze di pitivi a breve saranno sistemate (effetti e titolazione, tra l’altro creando una soluzione direttamente in gstreamer) e i vantaggi sono evidenti (editing video ‘di gruppo’ tramite telepathy, piani di sviluppo sul lungo termine, solidità di un progetto che non nasce per ‘accontentare gli utenti oggi’ ma pianificare uno sviluppo commericale nel lungo periodo)

    tutto questo senza contare che uno dei principali sviluppatori di pitivi + italiano😀

  2. @ Barra, parlo dell’inclusione nei repo. Comunque PiTiVi ti permette di tagliare i pezzi e riordinarli… non ci fai tanto! Almeno, io l’ho usato al massimo per tagliare un filmato in un certo periodo di tempo. Piuttosto che si concentrino per non far crashare ogni 2 secondi Kdenlive. Ok che è in Qt, ma è molto più maturo.😉
    @ Gabriel, non ho capito, mi sapresti dare più dettagli?🙂
    @ pablomoreno, be’ io ho già tradotto una parte dell’interfaccia di OpenShot. Quasi quasi se trovo il tempo mi metto col manuale, sarebbe una buona scusa per leggerlo.😀

  3. @Gabriel

    si era parlato anche di un discorso relativo allo ‘spazio utilizzato’. Sul disco di installazione (che è e restarà un cd ancora per molto tempo) non ci sta poi tantissima roba e pitivi non avrebbe nessuna dipendenza ‘extra’. Openshot si tira dietro altri 21mb di dipendenze, troppi dopo che per motivi di spazio è stato deciso di rimuovere gimp (e nei giri precedenti sono stati tolti sound-joucer ed ekiga).

  4. @Lazza:
    abbiamo risposto in contemporanea😀

    CMQ Pitivi nel ramo di sviluppo integra telepathy per creare una sorta di ‘editing di gruppo’ (utile in molte occasioni: tutti i file sono in locale e il canale passa solo ‘le modifiche’. Può capitare di avere una persona impegnata sulla titolazione e un’altro che invece lavora sull’audio). Oltre a questo la titolazione sarà introdotta entro febbraio grazie al supporto a non ricordo quale tecnologia open già presente.
    La completa riscrittura di pitivi (e di parte di gstreamer) consentiranno poi l’aggiunta di plugin in modo molto semplice (alla gnome-do): Integrazioni con brasero e simili arriveranno molto in fretta.

    questi post spiegano poi alcune cosette interessanti:
    http://blogs.gnome.org/edwardrv/2009/11/30/the-result-of-the-past-few-months-of-hacking/
    http://blogs.gnome.org/edwardrv/2009/11/20/answering-questions/

  5. @ Lazza

    Visto che Collabora, l’azienda che sta dietro a PiTiVi, contribuisce anche con lo sviluppo di Telepathy si pensa (non sono molto informato sulla reale situazione) di integrare Telepathy in PiTiVi, così da permettere l’editing collaborativo😉

  6. @Lazza
    Riprovalo kdenlive. L’ho usato per un progetto e nella versione 0.7.6 (Su arch linux) non ho riscontrato nessun crash. La situazione è moolto migliorata e mi sento di consigliarlo a chiunque ormai.

  7. Perche’ invece non fai in modo che venga aggiunto a Debian? cosi’ evitiamo che un’altro pacchetto viva soltato in ubuntu senza che venga portato su debian (che ne e’ downstream).

    E’ gente come te rende le due distro cosi’ diverse…

  8. @ Gabriel, ah ok ora ho inteso.
    @ lele85, boh proverò… Io mi attengo alle versioni che sono nei repo di Ubuntu.
    @ Sandro Tosi, adesso mi spieghi il senso del tuo intervento? Primo, non sono uno sviluppatore di OpenShot. Secondo, da quando in qua Ubuntu dev’essere l’esatta copia di Debian? Allora a ‘sto punto tanto vale usare Debian…

  9. Una distributione e’ molto piu’ di un insieme di pacchetti, quindi usare Ubuntu o Debian e’ ben diverso. Tu invece stai parlando di un singolo pacchetto, e stai cercando di farlo entrare in Ubuntu a tutti i costi. Convincere inceve a farlo includere in Debian aiuteresti sia gli utenti Debian, sia gli utenti Ubuntu che lo avrebbero “a gratis” quando Ubuntu fara’ il sync da Debian. 1 differenza in meno…

  10. Ok, però io sono utente Ubuntu ed avendo visto questa iniziativa fatta dagli sviluppatori di OpenShot ho pensato bene di aggiungere il mio “votino” e segnalare la cosa. Se tu hai voglia di fare un bug report per Debian secondo me è una bella idea.🙂

  11. tutto il rispetto a pitivi e sviluppatori, ma quel programma non serve a niente!
    O almeno, per me è inutile un programma che taglia i video e basta…magari in futuro diventerà un gran programma, ma per ora è meglio openshot per l’utente normale..

  12. OpenShot è ottimo, ma gli manca ancora la possibilità di sovrapporre sottotitoli e titoli ai filmati (caratteristica che peraltro non ritrovo in nessun altro video-editor per Linux, ad eccezione di Kdenlive).
    Per il resto, credo sia il miglior video-editor “casalingo” disponibile al momento per Gnome.

  13. Perché dici così?😦 OpenShot ha un wizard per creare dei buoni titoli, e con un pulsante puoi aprire Inkscape e usare tutta la sua potenza per modificarli!🙂 Infatti i titoli sono in SVG, con tutti i vantaggi che ne conseguono.😉

  14. In realtà Openshot 1.0 mi ha deluso.
    L’audio è gracchiante e la UI è lenta ma sopratutto mi è andato fuori sincrono audio-video effettuando un taglio su un .avi (idem per kdenlive, forse dipende dal comune framework sottostante MLT). PiTiVi invece mi ha fatto bene il lavoro sullo stesso file.

    Ecco un link a un articolo che confermerebbe la difettosita’ di OpenShot:
    http://www.osnews.com/story/22715/OpenShot_A_Prematurely_Released_Video_Editor

  15. Mitico! Non mi hai dato neanche il tempo di aprire il feed reader che ho subito visto il tuo commento con la bella notizia tra le email.😀

  16. Ho installato OpenShot ed ho riscontrato parecchi problemi:
    1. non riesco più ad usare gnome-app-install e software-center. Appena avviati si chiudono immediatamente.
    2. Non si avvia più Devede restituendo l’errore che non può avviarsi perchè non trova installati mplayer e mencoder (ma sono regolarmente installati e ho provato a disinstallare e reinstallare tutti e tre, risultato tutto resta fermo come prima).
    Come faccio a recuperare questi applicativi?
    Chiedo aiuto a chi a voglia di aiutare un disperato! Grazie

  17. Prima di suggerirti qualcosa vorrei sapere se hai installato openshot da PPA oppure da pacchetti debian scaricati sul sito. In entrambi i casi non ti preoccupare, è tutto facilmente risolvibile.😉

  18. La prima volta l’ho installato da pacchetto Debian e ho ottenuto gli
    inconvenienti descritti. In questa prima fase tutto si è risolto con il
    passaggio da Ubuntu 9.04 a 9.10 che ho aggiornato alcuni giorni dopo
    (con OpenShot disinstallato naturalmente).
    Questa volta l’ho installato da PPA ottenendo gli stessi inconvenienti.
    Grazie, ciao.

  19. Per prima cosa disattiva il PPA. Poi dai questi comandi da terminale:
    sudo aptitude purge -y openshot
    sudo aptitude reinstall -y ffmpeg/karmic mplayer/karmic
    sudo apt-get autoremove -y

    Dovrebbe sistemare praticamente tutto.

  20. for i in $( echo “openshot ffmpeg mplayer mencoder”); do aptitude show $i | egrep -i “(pacchetto|versione)”; echo “”; done

    questo è il risultato:

    Pacchetto: openshot
    Versione: 1.0.0-1
    Dimensione pacchetto installato: 21,3M

    Pacchetto: ffmpeg
    Versione: 5:0.5+svn20091116-0.4
    Dimensione pacchetto installato: 774k

    Pacchetto: mplayer
    Versione: 2:1.0~rc3+svn20090426-1ubuntu10
    Dimensione pacchetto installato: 5022k

    Pacchetto: mencoder
    Versione: 2:1.0~rc3+svn20090426-1ubuntu10.1
    Dimensione pacchetto installato: 3686k

  21. Come pensavo… Nessuno dei comandi che ti ho indicato è stato eseguito. Sei sicuro di averli dati correttamente? Attento che almeno uno ti chiederà la password quasi sicuramente.

  22. questo è ciò che ho fatto:

    antonio@antonio-desktop:~$ sudo aptitude purge -y openshot
    [sudo] password for antonio:
    Lettura elenco dei pacchetti… Fatto
    Generazione albero delle dipendenze
    Lettura informazioni sullo stato… Fatto
    Lettura delle informazioni sullo stato esteso
    Inizializzazione dello stato dei pacchetti… Fatto
    Nessun pacchetto verrà installato, aggiornato o rimosso.
    0 pacchetti aggiornati, 0 installati, 0 da rimuovere e 5 non aggiornati.
    È necessario prelevare 0B di archivi. Dopo l’estrazione, verranno occupati 0B.
    Scrittura delle informazioni sullo stato esteso… Fatto
    Lettura elenco dei pacchetti… Fatto
    Generazione albero delle dipendenze
    Lettura informazioni sullo stato… Fatto
    Lettura delle informazioni sullo stato esteso
    Inizializzazione dello stato dei pacchetti… Fatto

    antonio@antonio-desktop:~$ sudo aptitude reinstall -y ffmpeg/karmic mplayer/karmic
    Lettura elenco dei pacchetti… Fatto
    Generazione albero delle dipendenze
    Lettura informazioni sullo stato… Fatto
    Lettura delle informazioni sullo stato esteso
    Inizializzazione dello stato dei pacchetti… Fatto
    È possibile specificare un archivio solo con il comando «install».
    È possibile specificare un archivio solo con il comando «install».
    È possibile specificare un archivio solo con il comando «install».
    È possibile specificare un archivio solo con il comando «install».
    Nessun pacchetto verrà installato, aggiornato o rimosso.
    0 pacchetti aggiornati, 0 installati, 0 da rimuovere e 5 non aggiornati.
    È necessario prelevare 0B di archivi. Dopo l’estrazione, verranno occupati 0B.
    Lettura elenco dei pacchetti… Fatto
    Generazione albero delle dipendenze
    Lettura informazioni sullo stato… Fatto
    Lettura delle informazioni sullo stato esteso
    Inizializzazione dello stato dei pacchetti… Fatto

    antonio@antonio-desktop:~$ sudo apt-get autoremove -y
    Lettura elenco dei pacchetti… Fatto
    Generazione albero delle dipendenze
    Lettura informazioni sullo stato… Fatto
    0 aggiornati, 0 installati, 0 da rimuovere e 5 non aggiornati.
    antonio@antonio-desktop:~$

  23. Ok, allora è il secondo comando che dà problemi. Ti chiedo scusa, ho fatto un piccolo errore. Fai così:

    sudo aptitude install -y ffmpeg/karmic mplayer/karmic
    sudo apt-get autoremove -y

    Per favore però se devi postare output lunghi usa http://pastebin.ca come ti dicevo prima, grazie.😉

  24. Caspita… Allora proviamo una cosa di questo tipo.

    sudo apt-get clean

    Così ti pulisci la cache dei pacchetti. A questo punto apri il Gestore pacchetti (menu Sistema > Amministrazione) e cerca i pacchetti “ffmpeg” e “mplayer” e usa Pacchetto > Forza versione per retrocederli alla versione con di fianco scritto “karmic”. Accetta eventuali altre modifiche che ti vengono richieste ed applica il tutto.

  25. Ho forzato soltanto il pacchetto ffmpeg, perchè l’altro (mplayer) non me l’ha fatto forzare, e adesso è tutto OK!
    Grazie, sei mitico!

Che cosa ne pensi?

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...